basABFPrintExternVKBeleg Fehler

Dieses Thema im Forum "Warenwirtschaft" wurde erstellt von Bisut, 11. Juli 2019.

  1. Bisut

    Bisut Neues Mitglied

    Guten Tag,
    hoffe jemand kann uns helfen. Wir haben bei einem Endkunden der Sage100 (Belegdruck über AppDesigner); aber mit alter Oberfläche folgendes Problem beim Drucken von Belegen aus Verkauf oder Einkauf (auch völlig egal, welcher Beleg gedruckt wird); statt der Vorschaut kommt es zum basABFPrintExternVKBeleg Fehler bzw. basABFPrintExternEKBeleg; Der Hersteller Sage konnte uns bisher nicht helfen. Im Tracelog gibt es dazu keinen Fehler. Da wir beim Endkunden nur zwei PC haben, kommt der Fehler bei beiden PC (also unabhängig vom PC) oder Anmeldename in der Sage. Auf dem Server selbst haben wir den Fehler aber nicht. Wenn der Fehler kommt, muss PC dann runter gefahren werden, das hilft in der Regel zu 90% der Fälle. Dann kann oft auch mehrere Tage wieder normal gedruckt werden, dann kommt der Fehler irgendwann wieder. Einzige Maßnahme was wir noch nicht gemacht hatten, war eine komplette Deinstallation und Installation; aber vielleicht hat ja jemand eine Idee?
    Gruß Uwe
     

    Anhänge:

  2. mandreck

    mandreck Mitglied

    Ähnliche Fehlermeldungen an Mass haben wir auch bei Kunden erhalten, die wir von 5.6,7 Versionen auf die 8.x migriert haben. Unsere Lösung hier war, alle AppDesigner Verkaufsbelege zu eliminieren und den Kunden auf den neuen ReportDesigner (Stimusoft) umzustellen. Hatte auch den Vorteil einer allgemeinen Fehlerbereinigung beim Kunden und das Programm wurde auf die aktuele Version umgestellt ohne Altlasten. printAdin und AppDesigner für Druckbelege scheinen endgültig der Vergangenheit anzugehören, auf alle Fälle bei Nutzung der neuen Oberflächen.
    Auch bei uns konnte der Support nicht weiterhelfen und wollten DB etc. vom Kunden haben, hat alles nichts gebracht, außer das Du Deinen Kunden verärgerst wenn Du da auf Ergebnisse wartest.
    In den erweiterm Layout des Report Designers sind sichtbare Überladungen aufgetreten die sich angeblich auch keiner erklären konnte. Wir haben dann alles selbst von Hand erledigt. Wenn man den ganzen Altmüll mal weg hat, lässt es sich mit dem ReportDesigner gut arbeiten.
     
    KMoeser gefällt das.
  3. Bisut

    Bisut Neues Mitglied

    Wir konnten das Verhalten nun weiter eingrenzen und den Fehler "noch" nicht wieder reproduzieren. Zumindest kommt der Fehler nicht mehr! Es schien Probleme in der WebException vorzuliegen. Das Netzwerk dort konnte wohl nicht ständig die korrekte Remotenamen vom Server darstellen. Wir haben dort in der hosts nicht nur die UNC sondern den kompletten Namen aus der AppDesigner ausgelesen und dort hinterlegt. UNC war zwar schon vorher korrekt, aber das Netzwerk dort hat diesen anscheinend nicht ständig behalten. Somit steht jetzt "Nameserver.Nameserver.local" und das scheint zu funktionieren. Hoffen, das dieses jetzt so bleibt.
     
  4. mandreck

    mandreck Mitglied

    Der Weg über eine manipulierte Host Datei auf jeder lokalen Maschine ist aber schon eine Krücke. Die man vermeiden sollte (muss) zu große Angriffsmöglickeiten. Eine saubere Namensauflösung im Netz und ordentliche UNC Pfade sollten reichen. Empfehlung eventuell noch feste IP Adressen für die einzelnen Stationen (WS und Drucker) zu verwenden.
     

Diese Seite empfehlen