Funktionsstamm AC

Dieses Thema im Forum "Aufgabencenter" wurde erstellt von TottoW, 20. August 2020.

  1. TottoW

    TottoW Neues Mitglied

    Hallo zusammen,

    wenn ich in einer DP die Funktion "Artikel bearbeiten" funktioniert diese in der alten Ansicht in SAGE100, aber nicht in der ´neuen Ansicht:

    gbOpenStammdatenArtikel("[$Spalte:Artikelnummer:Quote()]", "[$Spalte:AuspraegungID]")

    Hat jemand eine Idee dazu, wie ich jetzt den Artikelstamm in der neuen Ansicht aufrufen kann?

    Danke im Voraus

    Gruß
    Totto
     
  2. m.becker

    m.becker ESC GmbH Mitglieder

    Hallo,

    die Funktion sollte eigentlich auch den neuen Artikelstamm öffnen, zumindest funktioniert es bei uns so:

     
  3. TottoW

    TottoW Neues Mitglied

    Hallo Herr Becker,

    vielen Dank für die Rückmeldung.

    Bei mir erscheint folgende Meldung:

    upload_2020-8-21_6-19-6.png
     
  4. TottoW

    TottoW Neues Mitglied

    Hallo Herr Becker,

    ich habe den Fehler gefunden.
    Im Funktionsstamm der OL8.1 habe ich den oben angegebenen Quellcode.
    In der DP ist jedoch dieser (aus der OL7.0) hinterlegt:
    gbFrmOpenLookup("frmAbfDataArtikel", "[$Spalte:Artikelnummer:Quote()]#*#[$Spalte:AuspraegungID]")

    Danke noch einmal.
     
    m.becker gefällt das.
  5. TottoW

    TottoW Neues Mitglied

    Noch einmal ich,

    ist es möglich den Artikel auch in der Masteransicht zu fokussieren?

    Danke im Voraus
     
  6. m.becker

    m.becker ESC GmbH Mitglieder

    Das funktioniert bei mir in der 9.0 automatisch. Ich glaube, Sage hat das irgendwann mal per Update nachgeliefert. Vielleicht fehlt in der 8.1 nur ein LiveUpdate?
     
    TottoW gefällt das.
  7. TottoW

    TottoW Neues Mitglied

    Hallo zusammen,

    die Meldung das das frmAfDataArtikel nicht gefunden werden konnte, hatte die auch schon einmal jemand bei der Umstellung auf die OL8.1 oder höher?

    Danke im Voraus
    Gruß
    Totto
     
  8. m.becker

    m.becker ESC GmbH Mitglieder

    Moin,

    ich hatte es noch bei keiner Umstellung. Wenn tatsächlich frmAfDataArtikel nicht gefunden wird, fehlt auch das "b" in "Abf".
     
  9. TottoW

    TottoW Neues Mitglied

    Moin moin Herr Becker,

    sorry, so sieht die Meldung aus:

    2450
    Sage 100 Warenwirtschaft kann das Formular 'frmAbfDataArtikel' nicht finden, auf das verwiesen wird.
    HintergrundInfo:
    (Set frm = goapplication.oSageApplication.forms("frmAbfDataArtikel"))


    Gruß
    TottoW
     
    Zuletzt bearbeitet: 27. August 2020
  10. esc_hein

    esc_hein Mitglied Mitglieder

    Hallo,

    meiner Einschätzung nach kann die obige Codezeile nur mit der "alten" Access-Stammdatenmaske funktionieren (Zugriff auf ein geöffnetes Access-Formular). Sofern die Umstellung auf die neuen Oberflächen bereits erfolgt ist wird man andere Lösungswege finden müssen um die Anforderung umzusetzen.
     

Diese Seite empfehlen