Datenpräsentationen nach gewisser Zeit nicht mehr verfügbar

HibikeChc

Neues Mitglied
Hallo alle zusammen,

ich bin neu, was die OL Nutzung und das Aufgaben-Center angeht und stehe leider direkt vor einem großen Problem. Auf Wunsch der Mitarbeiter habe ich einige zusätzliche Datenpräsentationen im Aufgabencenter erstellt. Soweit funktionieren diese Datenpräsentationen auch tadellos und erfüllen ihren Zweck. Allerdings werden diese nach einer gewissen Zeit nicht mehr im Hauptmenü angezeigt. Versucht man in diesem Fall eine Datenpräsentation über die Favoriten zu öffnen, so bekommt der Nutzer die Fehlermeldung: "Diese Funktion steht nicht zur Verfügung.". Nach einem Neustart der OL werden die Datenpräsentationen wieder ganz normal angezeigt und können normal genutzt werden.

Allerdings tritt dieses Phänomen nur bei von mir neu angelegten Datenpräsentationen auf. Bei den Datenpräsentationen von meinem Vorgänger (welcher leider sehr plötzlich verstarb) tritt dieses Phänomen nicht auf.

Hat jemand schon mal mit dieser Fehlermeldung Bekanntschaft gemacht? Oder kennt gar dieses Problem? Ich konnte dazu leider nicht finden.

Mit freundlcihen Grüßen,
Christian
 

Bisut

Aktives Mitglied
Spontan fällt mir dazu nichts ein. Ich würde an deiner Stelle über die "Datenpräsentation" in der Konfiguration nachsehen, wie dein Vorgängern die Einstellungen vorgenommen hat und diese mit deiner zu vergleichen. Aber vielleicht hast du das schon gemacht. Was bedeutet das genau (nicht mehr im Hauptmenü?; bist du da sicher, das das Fenster wirklich weg ist. In dem Fall würde ich mal oben in den Fenstern schauen, ob diese einfach nur in den Hintergrund ist. Die Frage ist natürlich, wie lange bleibt die AC Darstellung offen? Ich kann mir da nur vorstellen, das der Anwender einfach zu viele Fenster geöffnet hat? Das sich das Fenster nach einer gewissen Zeit wieder von selbst schließt, hatte ich bisher nicht.
 

Bisut

Aktives Mitglied
In dem Fall, habe ich erst die AC Lösung im Fenster geöffnet, dann weitere Sage Fenster. Oben in der Ecke gibt es die Fenster Technik von Sage, wo man auf die einzelnen Fenster klicken kann, bzw. hier anders anordnen könnte (je nach Geschmack). Vielleicht ist das Fenster noch da - aber dann nicht mehr aufrufbar. Das würde ich einfach nochmal prüfen.

Sage_Fenster.png
 

HibikeChc

Neues Mitglied
Hallo,

vielen Dank für die schnelle Antwort!

Das Phänomen ist wirklich ganz kurios. Ich habe es tatsächlich auch gerade das erste Mal selber erlebt. Ich hatte während einem Meeting die OL im Hintergrund offen gelassen. Als ich nach dem Meeting in die OL schaute war es passiert...Alle von mir mit dem AC geschriebenen Datenpräsentationen waren auf ein mal nicht mehr im Hauptmenü zu finden. Sogar die Ornder der neuen Datenpräsentationen werden nicht mehr angezeigt. Die Einträge sind einfach weg. Beim Versuch die Datenpräsentationen über die Favoriten zu öffnen, kommt die besagte Fehlermeldung. Leider hatte ich keine neue Datenpräsentation offen gelassen. Wäre interessant zu wissen, ob sich diese tatsächlich geschlossen hätten.

Jetzt kommt allerdings das wirklich kuriose: Alte Datenpräsentationen meines Vorgängers waren auf einmal wieder im Hauptmenü zu finden. Und das, obwohl ich diese deaktiviert habe! Ich habe extra noch mal im AC Konfigurator nachgeschaut, diese sind definitiv deaktiviert. Diese lassen sich aber auch nicht öffnen. Es passiert einfach nichts. Ähnlich, als würde man im laufenden Betrieb eine Datenpräsentation deaktivieren und dann versuchen diese zu öffnen.

Hat irgendjemand irgendeine Erklärung, wie etwas derartiges passieren kann? Klingt so, als wäre es irgendwo hinterlegt, dass ab einem gewissen Zeitpunkt die Datenpräsentationen des AC neubezogen werden. Allerdings warum auch immer von einer alten Version. Ist soetwas denn überhaupt möglich?

Ich bin für jeden Tipp dankbar! Tappe leider komplett im dunklen.

Mit freundlichen Grüßen,
Christian
 

Bisut

Aktives Mitglied
@HibikeChc = Hallo Christian,
ich würde die komplette Datenbank Verbindung neu machen. Irgendwie habe ich das Gefühl das es zwei unterschiedliche sind und diese nicht korrekt gefunden werden. Im AC Konfiguration gibt es auf der linken Seite im Hauptmenü die Funktion "Datenverbindungen" dort ist die Verbindung zu der Sage Datenbank gesteuert. Die AC hat ja den Vorteil, das man Datenansichten auch aus anderen Verbindungen schaffen kann. Als bezogen auf SQL Ebene. Was wir auch schon bei einigen Projekten so gemacht haben. In den Verbindungen ist dort die einzelnen Verbindungen zur Datenbank der Sage verlinkt. Denke das ist der Grund das hier mal das eine und mal das andere drin steht. Ferner sollte man sich auch in den Strukturen diese Verbindung näher ansehen. Beim Anlegen der Struktur muss zwangsweise eine Verbindung zur Datenbank vorhanden sein. Da scheint mir das Problem zu liegen. Wenn Sie da nicht weiterkommen, bittte hier kurz posten, dann können wir hier auch gerne gemeinsam drauf schauen per Fernwartung.
Gruß Uwe
 

HibikeChc

Neues Mitglied
Hallo Zusammen,

@Bisut Vielen lieben Dank für die Antwort!
Ich habe die letzte Woche einiges bei den Datenverbindungen ausprobiert. Es waren tatsächlich alle Verbindungen doppelt hinterlegt, mit sowohl der selben Bezeichnung als auch der selben IP Adresse als Servernamen. Ich habe erstmal testweise immer eine dieser Verbindungen umbenannt. Letztendlich ließ sich so feststellen, dass fast immer nur eine dieser beiden Verbindungen bei den Datenpräsentationen etc überhaupt verwendet wurde. Rückschließend würde ich sagen, dass diese für Tests genutzt wurden. Da das Problem trotz Umbenennung der Dopplungen weiterhin auftrat, habe ich die entsprechenden Dopplungen zunächst gelöscht. Nach wiederholtem auftreten des Problems habe ich dann alle Datenverbindungen neu gemacht. Leider tritt das Problem allerdings weiterhin auf.
Das Angebot bezüglich einer Fernwartung würde ich sehr gerne wahrnehmen.

Mit freundlichen Grüßen,
Christian
 

HibikeChc

Neues Mitglied
Hallo,

die von mir neu erstellten und aktuell genutzten Datenpräsentationen haben alle einen eindeutigen Schlüssel. Nur die in meiner Teststruktur haben keine. Es sind allerdings alle von mir erstellten Datenpräsentationen betroffen.

Die Datenpräsentationen meines Vorgängers hingegen haben nur vereinzelt eindeutige Schlüssel.

Mit freundlichen Grüßen,
Christian
 
Oben